HomeCalendarGalleryFAQSearchMemberlistUsergroupsRegisterLog in
Latest topics
» what up yall
27th August 2010, 10:21 pm by Blaze

» Count to 6000
12th July 2010, 4:03 am by Dribbler

» meal of the day
1st July 2010, 6:52 am by Dribbler

» What are you doing?
29th June 2010, 8:55 pm by Mostafa

» hey hey
3rd June 2010, 1:16 am by seth

» punkbusterA and shit
2nd June 2010, 12:40 pm by marn!k

» Hello
28th May 2010, 9:39 am by Dribbler

» show your skill :D
27th May 2010, 11:35 am by Dribbler

» ABC of Words
26th May 2010, 6:58 am by Dribbler

 

PAY UP MOFO

Game Servers UK

Share | 
 

 Could not load openGL subsystem

View previous topic View next topic Go down 
AuthorMessage
Raider
Owner
avatar

Join date : 2010-04-29
Age : 35

PostSubject: Could not load openGL subsystem   1st May 2010, 11:06 am

.:VC:. WIKI page: Could not load OpenGL subsystem

Could not load OpenGL subsystem
Question I receive the error: Could not load OpenGL subsystem. Answer Check to make sure you have a supported 3D video card to play the game. Return to Castle Wolfenstein requires that you have one of the supported 3D cards to play the game. Your card must have 100% OpenGL support and at least 16 MB of memory. A list of the supported chipset is listed in the minimum system requirements.

Make sure you have the latest video and sound card drivers from the manufacturers' websites.
If you have a motherboard with an onboard video card you need to disable it in the system BIOS. Refer to your motherboard manual and/or contact your motherboard manufacturer on how to do this.
If you are using a video card which supports dual monitors, the secondary monitor must be disabled for OpenGL to initialize correctly.

For Windows 98 and ME:
Make sure the 3D hardware acceleration is turned all the way up.
1) Right-click on the My Computer icon on the desktop and select Properties.
2) Select the Performance tab and click the Graphics button.
3) Make sure the acceleration slider is set to Full.

For Windows XP and 2000:
1) Click on the Start button > Settings > Control Panel.
2) Double-click the Display icon.
3) Click the Settings tab.
4) Click the Advanced button.
5) Click the Troubleshoot tab.
6) Make sure the acceleration slider is set to Full.

Set your desktop settings to 640 by 480 and High Color (16 bit).
All background applications must be shutdown prior to running the game.

If after trying the above solutions the game still does not work, check the following:
1) Click on the Start button > Run and in the run box type "Sysedit" without the quotes and click the OK button.
2) When Sysedit comes up you should see a bunch of cascaded windows, select the window that says Win.ini above it.
3) The Win.ini window should come to the foreground, scroll through the list of items until you come to [DrawDib].
4) Look for a line under [DrawDib] that says DVA=0 and remove it.
5) Click File, then Save and close the Sysedit program.
6) Try the game at this point.

If you do not see the DVA=0 line under the [DrawDib] section, then this is not the cause of your problem. DVA stands for Direct Video Access, and is commonly set to 0 to fix issues with older games or video problems with old software. Unfortunately it causes Return to Castle Wolfenstein to not recognize OpenGL support on your system as well. The only way to fix this is to remove that line. This should not affect anything on your system.

Set your virtual memory to a fixed size.
1) Right-click on My Computer and select Properties.
2) Click the Advanced button, click on Performance settings.
3) Click the Advanced tab, click the Change button.
4) Set the Virtual Memory to a minimum and maximum size of 600MB.
5) Confirm your selections until at the desktop - you may need to reboot.

NOTE: These steps are specific to Windows XP, Windows NT and 2000 may differ slightly.

This will occur when insufficient Virtual Memory is available for the game. For the best performance and stability under Windows NT, 2000 and XP you should aim for having at least 600MB of virtual memory available.

Turn off GL Extensions in the game by changing the configuration file.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the wolfconfig.cfg file which is located in the Return to Castle Wolfenstein\Main directory on your machine.
3) Locate the line reading:

seta r_allowExtensions "1"

4) Change the 1 to a 0.
5) Click File > Save.

If you are not using a 3Dfx video card, disable the WickedGL support in the game.
1) Click the Start button > Programs > Accessories > Wordpad.
2) Open the WOLFCONFIG.CFG file located in the C:\...\Return to Castle Wolfenstein\Main directory.
3) Located a line reading:

seta r_glIgnoreWicked3D "0"

4) Change the "0" to a "1".
5) Save the file.

It is possible the game is having issues generating the configuration file on it's first run. Try downloading and installing the wolfconfig.cfg file listed below to the game's \MAIN directory.

If you are using a 3Dfx video card try copying the custom 3dfx OpenGL files into the System directory.
1) Use My Computer to navigate to the Return to Castle Wolfenstein drive on your hard drive.
2) Double-click the GL folder
3) Click Edit then Select All.
4) Click Edit then Copy.
5) Again using My Computer, go to the C:\WINDOWS\SYSTEM* folder.
6) Click Edit, then paste. Do not overwrite any existing files.

* This directory name will change depending on what version of Windows you have.

Windows 95,98,ME: - C:\WINDOWS\SYSTEM
Windows 2000, NT: - C:\WINNT\SYSTEM32

Windows XP Users:
Please note that the default drivers that come with Windows XP are NOT OpenGL compatible. You will need to go to the video card or video chip manufractor and obtain the latest Windows XP compatible drivers with OpenGL support. This is especially true for ATi and nVidia based video cards.

___

Dopebagz: Found a fix for gl subsystem:

Download these 2 dll's. Extract and paste them into your windows/system folder. NOT windows/system32.

msvcr71.dll
msvcp71.dll

This is the only real fix that worked for many people.

Thanks to .:VC:.WIKI page
Back to top Go down
View user profile http://cbk-clan.forumandco.com
 

Could not load openGL subsystem

View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
 :: General :: Help-